A fix has been implemented and we are monitoring the results.
Posted Nov 26, 2025 - 10:21 CET
Investigating
We are currently experiencing some delays in the Report API impacting transactions listing in GetPaid app and Merchant Portal. We are currently investigating the issue.
Posted Nov 26, 2025 - 10:18 CET
This incident affected: Get Paid App and Report API.